PurePicBasic - Asm

Forum de développement du compilateur asm / basic pour les puces microchip
 
AccueilAccueil  RechercherRechercher  S'enregistrerS'enregistrer  Connexion  

Partagez
 

 Erreur avec les gotos

Aller en bas 
Aller à la page : Précédent  1, 2
AuteurMessage
wood51

wood51

Messages : 72
Date d'inscription : 20/01/2013
Age : 39
Localisation : Orléans

Erreur avec les gotos - Page 2 Empty
MessageSujet: Re: Erreur avec les gotos   Erreur avec les gotos - Page 2 EmptyMer 23 Jan - 19:25

Cpl.Bator a écrit:
j'aurais mis goto $-8 au lieu de -7 ?

Euhh scratch
Le code ci dessus c'est moi qui l'est modifié, tu avait mis des labels et avec les labels sa fonctionne nickel
Revenir en haut Aller en bas
Cpl.Bator
Admin


Messages : 50
Date d'inscription : 20/01/2013

Erreur avec les gotos - Page 2 Empty
MessageSujet: Re: Erreur avec les gotos   Erreur avec les gotos - Page 2 EmptyMer 23 Jan - 20:19

oui je le sais, je disait juste que ton code modifier à une erreur , le dernier goto $-7 n'est pas bon.
Revenir en haut Aller en bas
http://purepicbasic.frenchboard.com
wood51

wood51

Messages : 72
Date d'inscription : 20/01/2013
Age : 39
Localisation : Orléans

Erreur avec les gotos - Page 2 Empty
MessageSujet: Re: Erreur avec les gotos   Erreur avec les gotos - Page 2 EmptyMer 23 Jan - 20:24

Ok dsl , je viens de modif mais pas d'amélioration
ca me donneun goto -31

Edit : c'est bien $-7 , les labels ne sont pas considérés comme instruction Wink
Re-edit : Le pb survient dès que il y a plus d'un goto du style goto $ +/- xxx
Revenir en haut Aller en bas
Cpl.Bator
Admin


Messages : 50
Date d'inscription : 20/01/2013

Erreur avec les gotos - Page 2 Empty
MessageSujet: Re: Erreur avec les gotos   Erreur avec les gotos - Page 2 EmptyMer 23 Jan - 20:45

ok. je cafouille...

je vais revoir en profondeur le compilateur, surtout pour les erreurs de syntaxe.
je prototype le code suivant :
par exemple , definition de la grammaire pour le mot #DEFINE :

Code:
; -----------------------------------------------------------------------------
; #DEFINE CONST 1
; -----------------------------------------------------------------------------
*tmp = _create_token_rules_(#TOKEN_TYPE_PREPROCESSOR,"#DEFINE")
_push_token_rule_(*tmp, #TOKEN_TYPE_UNKNOWN)
_push_token_rule_(*tmp, #TOKEN_TYPE_NUMERIC)
_push_token_rule_(*tmp, #TOKEN_TYPE_END_OF_INSTRUCTION)
 
; -----------------------------------------------------------------------------
; #DEFINE CONST OTHERCONST
; ----------------------------------------------------------------------------- 
*tmp = _create_token_rules_(#TOKEN_TYPE_PREPROCESSOR,"#DEFINE")
_push_token_rule_(*tmp, #TOKEN_TYPE_UNKNOWN)
_push_token_rule_(*tmp, #TOKEN_TYPE_PREPROCESSOR)
_push_token_rule_(*tmp, #TOKEN_TYPE_END_OF_INSTRUCTION)

; -----------------------------------------------------------------------------
; #DEFINE CONST 1 AT 0x0000
; -----------------------------------------------------------------------------
*tmp = _create_token_rules_(#TOKEN_TYPE_PREPROCESSOR,"#DEFINE")
_push_token_rule_(*tmp, #TOKEN_TYPE_UNKNOWN)
_push_token_rule_(*tmp, #TOKEN_TYPE_NUMERIC)
_push_token_rule_(*tmp, #TOKEN_TYPE_PREPROCESSOR,"AT")
_push_token_rule_(*tmp, #TOKEN_TYPE_NUMERIC)
_push_token_rule_(*tmp, #TOKEN_TYPE_END_OF_INSTRUCTION)

; -----------------------------------------------------------------------------
; #DEFINE CONST 'A'
; -----------------------------------------------------------------------------
*tmp = _create_token_rules_(#TOKEN_TYPE_PREPROCESSOR,"#DEFINE")
_push_token_rule_(*tmp, #TOKEN_TYPE_UNKNOWN)
_push_token_rule_(*tmp, #TOKEN_TYPE_CHARACTER)
_push_token_rule_(*tmp, #TOKEN_TYPE_END_OF_INSTRUCTION)
Revenir en haut Aller en bas
http://purepicbasic.frenchboard.com
wood51

wood51

Messages : 72
Date d'inscription : 20/01/2013
Age : 39
Localisation : Orléans

Erreur avec les gotos - Page 2 Empty
MessageSujet: Re: Erreur avec les gotos   Erreur avec les gotos - Page 2 EmptyMer 23 Jan - 20:53

Tu travail sur quel type d'analyseur ? récursif ou avec table ?
Revenir en haut Aller en bas
Cpl.Bator
Admin


Messages : 50
Date d'inscription : 20/01/2013

Erreur avec les gotos - Page 2 Empty
MessageSujet: Re: Erreur avec les gotos   Erreur avec les gotos - Page 2 EmptyMer 23 Jan - 20:59

C'est pas du "standard" , tu sais je viens des sentier battu... Very Happy
cela s'approche de l'analyse récursive descendante.
Revenir en haut Aller en bas
http://purepicbasic.frenchboard.com
wood51

wood51

Messages : 72
Date d'inscription : 20/01/2013
Age : 39
Localisation : Orléans

Erreur avec les gotos - Page 2 Empty
MessageSujet: Re: Erreur avec les gotos   Erreur avec les gotos - Page 2 EmptyMer 23 Jan - 21:07

Cpl.Bator a écrit:
C'est pas du "standard" , tu sais je viens des sentier battu... Very Happy

Tu sais la d'où je viens en programmation je sais même si il y avais des sentiers lol!

Cpl.Bator a écrit:
cela s'approche de l'analyse récursive descendante.
c'est marrant , c'est exactement ce que je fais pour la partie basic . Merci le bouquin ( qu'on as en commun puisque j'ai le même à la maison ) , Merci toi pour l'analyse lexical et merci google !!!

PS : Tu as jeté un petit coup d'oeil au code Basic histoire de me dire ?
Revenir en haut Aller en bas
Cpl.Bator
Admin


Messages : 50
Date d'inscription : 20/01/2013

Erreur avec les gotos - Page 2 Empty
MessageSujet: Re: Erreur avec les gotos   Erreur avec les gotos - Page 2 EmptyMer 23 Jan - 21:17

je me suis pas penché dessus , la partie asm me bouffe tout le temps.
je regarderais en rentrant du taf demain Wink
Revenir en haut Aller en bas
http://purepicbasic.frenchboard.com
Contenu sponsorisé




Erreur avec les gotos - Page 2 Empty
MessageSujet: Re: Erreur avec les gotos   Erreur avec les gotos - Page 2 Empty

Revenir en haut Aller en bas
 
Erreur avec les gotos
Revenir en haut 
Page 2 sur 2Aller à la page : Précédent  1, 2

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
PurePicBasic - Asm :: PurePicAsm-
Sauter vers:  
Ne ratez plus aucun deal !
Abonnez-vous pour recevoir par notification une sélection des meilleurs deals chaque jour.
IgnorerAutoriser